Dashboard Login Degradation

Incident Report for Balance

Resolved

This incident has been resovled
Posted Oct 29, 2025 - 16:49 UTC

Monitoring

A fix has been implemented, and we're currently monitoring to ensure full stability.
Posted Oct 29, 2025 - 16:44 UTC

Identified

We're currently experiencing an issue with one of our third-party providers that may affect dashboard logins for users in certain regions. Our team is actively working to resolve the issue.
Posted Oct 29, 2025 - 16:36 UTC
This incident affected: Platform.