Degraded performance on Sandbox

Incident Report for Balance

Resolved

Issue resolved
Posted Sep 15, 2021 - 08:25 UTC

Update

We are investigating the issue
Posted Sep 15, 2021 - 08:14 UTC

Investigating

We are currently investigating this issue.
Posted Sep 15, 2021 - 08:13 UTC
This incident affected: Sandbox Environment.