Our authentication service is down due to Cloudflare outage in some regions.

Incident Report for Balance

Resolved

This incident has been resolved.
Posted Jun 21, 2022 - 07:32 UTC

Investigating

We are currently investigating this issue.
Posted Jun 21, 2022 - 06:57 UTC
This incident affected: Platform.