Qualification and Credit services degradation

Incident Report for Balance

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:03 UTC

Monitoring

A fix has been implemented and out team is monitoring it.
Posted Jun 12, 2025 - 20:07 UTC

Update

We are continuing to work on a fix. We're also seeing issues with the Transaction Confirmation endpoint.
Posted Jun 12, 2025 - 19:42 UTC

Identified

A fix is being deployed
Posted Jun 12, 2025 - 19:35 UTC

Investigating

Due to a global outage on Google Cloud Platform - Customer may experience issues with Qualification and Credit APIs
Posted Jun 12, 2025 - 18:57 UTC
This incident affected: API and Sandbox Environment.