Partial Outage

Incident Report for Balance

Resolved

There was a Stripe and Fastly outage issue. This issue is now resolved.
Posted Jun 08, 2021 - 11:33 UTC

Investigating

We're currently investigating an issue with the Sandbox environment and Dashboard
Posted Jun 08, 2021 - 10:33 UTC
This incident affected: Platform and Sandbox Environment.