Dahsboard Login Degradation

Incident Report for Balance

Resolved

3rd party issue resolved and tested on our end as well.
Posted May 31, 2023 - 14:26 UTC

Identified

Some users might experience issues logging in to the Balance dashboard.
This is due to a 3rd party authentication service experiencing issues.
Posted May 31, 2023 - 14:09 UTC
This incident affected: Platform.