We are observing stable performance across all Balance services. AWS continues to perform remediation efforts related to their ongoing incident. While all Balance systems are currently operational, intermittent issues may still occur until AWS fully completes their recovery process. Our teams are closely monitoring system health and coordinating with impacted service providers to ensure continued stability. We will provide another update once AWS confirms full resolution or if there are any changes in service performance.
Posted Oct 20, 2025 - 23:06 UTC
Update
We are currently experiencing a global disruption due to a widespread incident impacting AWS services. As a result, several Balance services are experiencing degraded performance, including (but not limited to): - Dashboard and Buyer Portal login - Bank account connection - Invoice and Receipt generation
All payment-related functionality remains operational. Buyer qualification is operational (except for bank account connection).
We are monitoring AWS recovery efforts closely and will restore full functionality as soon as the incident is resolved. We will continue to post updates as more information becomes available.
Posted Oct 20, 2025 - 18:49 UTC
Identified
We are currently experiencing an issue where connecting a bank account is not operational. The disruption is caused by a global incident affecting a third-party service provider. Our team is actively monitoring the situation and will restore full functionality as soon as the third-party issue is resolved. We’ll continue to provide updates here as more information becomes available.
Posted Oct 20, 2025 - 16:34 UTC
This incident affected: Platform, Qualification, Payment Method Management, and Buyer Portal.