Delay in Email Delivery

Incident Report for Balance

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 10:02 UTC

Identified

We are currently experiencing delays in the delivery of emails sent from our platform. We have identified the root cause of the issue and are actively working on implementing a resolution.

During this time, email delivery may continue to be delayed. No messages have been lost.

We will share updates as progress is made and notify you once the issue is fully resolved.
Posted Jul 10, 2025 - 15:04 UTC
This incident affected: Platform.